搬瓦工VPS安装LNMP失败怎么办 准确安装LNMP的方法

我们很多人购买搬瓦工VPS的目的纯粹是为了搭建一个网站,搭建网站,首先需要安装网站环境,比如常见的LNMP、LAMP、宝塔等,今天和大家分享的是LNMP以及在安装LNMP时可能会出现的一些问题,导致搬瓦工VPS安装不顺利,那么如何准确的安装LNMP呢?

一、搬瓦工VPS安装LNMP

LNMP作为一个比较流行的web生产环境,一键脚本也比较多,当我们发现LNMP安装失败的时候,首先想到的是检查以下几个问题:

1、VPS内存过小 

如果安装MySQL 5.6或5.7及MariaDB 10的话,VPS必须1G以上内存,更高版本至少要2G内存,安装PHP 7及以上版本必须1G以上内存。

2、VPS系统太新或者太老 

CentOS 5,Debian 6及之前版本其官网已经结束支持无法使用。

PHP 7.1.*以下版本不支持Ubuntu 19+、Debian 10等等非常新的Linux发行版。

PHP 7.4升级或安装必须CentOS 8+,Debian 8+,Ubuntu 16.04+且必须使用1.7。

MySQL 8.0升级或安装必须CentOS 8+,Debian 9+,Ubuntu 16.04+且必须使用1.7。

3、LNMP版本问题 

Ubuntu 18+,Debian 9+,Mint 19+,Deepin 15.7+及所有新的Linux发行版只能使用LNMP1.6及以上的版本进行安装。

有些朋友安装LNMP的时候可能并不是直接去官方的网站复制的最新的命令,而是搜索到的一些以前的旧文章教程,里面的LNMP版本过低的话,加上VPS系统比较新,就容易导致安装失败。

所以大家在安装LNMP的时候,注意看一下安装命令里的数字,lnmp1.5/lnmp1.6这一类的,或者直接去官方网址复制最新的安装命令。

4、上传日志到官方论坛解决 

如果我们自己并不能判断或解决问题,可以把VPS的/root目录下的lnmp-install.log,发到LNMP的交流论坛,大概率会得到解决的回复。

二、搬瓦工推荐方案

方案CPU内存硬盘流量/带宽机房价格购买链接
CN2常规
(最便宜方案)
1核1GB20GB SSD1TB/月 1GbDC3 CN2
DC8 ZNET
$49.99/年查看购买
CN2 GIA-E
(最具性价比方案)
1核2GB20GB SSD1TB/月 2.5GbDC6 CN2 GIA-E
DC9 CN2 GIA
日本大阪软银
$49.99/季度
$169.99/年
查看购买
HK香港方案
(高端方案)
2核2GB40GB SSD0.5TB/月 1Gb香港 CN2 GIA
香港 PCCW
$89.99/月 $899.99/年查看购买

三、搬瓦工所有方案

如果想要了解或选择更多在售搬瓦工方案,可以查看这篇文章:《搬瓦工所有在售方案配置及最新搬瓦工优惠码2021年》

四、搬瓦工购买教程

2021年搬瓦工最新购买教程可以查看这篇文章:《2021年搬瓦工购买教程图文详解附支付宝支付教程》

以上就是搬瓦工VPS安装LNMP失败怎么办 准确安装LNMP的方法的详细介绍,如果有需要的可以看看。

 

 

未经允许不得转载:搬瓦工VPS中文网 » 搬瓦工VPS安装LNMP失败怎么办 准确安装LNMP的方法